Buffer overflow in Linux kernel - CVE-2014-3182

 

Buffer overflow in Linux kernel - CVE-2014-3182

Published: September 28, 2014 / Updated: August 10, 2020


Vulnerability identifier: #VU41279
CSH Severity: High
CVSS v4: 8.6 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-3182
CWE-ID: CWE-119
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

Array index error in the logi_dj_raw_event function in drivers/hid/hid-logitech-dj.c in the Linux kernel before 3.16.2 allows physically proximate attackers to execute arbitrary code or cause a denial of service (invalid kfree) via a crafted device that provides a malformed REPORT_TYPE_NOTIF_DEVICE_UNPAIRED value.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-trusty (Ubuntu package)

How to mitigate CVE-2014-3182

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 3.2.0-70.105, 3.13.0-39.66
linux-lts-trusty (Ubuntu package) - update to 3.13.0-39.66~precise1

External References

Related Security Bulletins