Resource management error in Linux kernel - CVE-2014-6418

 

Resource management error in Linux kernel - CVE-2014-6418

Published: September 28, 2014 / Updated: August 10, 2020


Vulnerability identifier: #VU41287
CSH Severity: Medium
CVSS v4: 8.7 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-6418
CWE-ID: CWE-399
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

net/ceph/auth_x.c in Ceph, as used in the Linux kernel before 3.16.3, does not properly validate auth replies, which allows remote attackers to cause a denial of service (system crash) or possibly have unspecified other impact via crafted data from the IP address of a Ceph Monitor.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-trusty (Ubuntu package)

How to mitigate CVE-2014-6418

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 3.2.0-70.105, 3.13.0-37.64
linux-lts-trusty (Ubuntu package) - update to 3.13.0-37.64~precise1

External References

Related Security Bulletins