Input validation error in Google products - CVE-2014-3169

 

Input validation error in Google products - CVE-2014-3169

Published: August 27, 2014 / Updated: August 10, 2020


Vulnerability identifier: #VU41369
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-3169
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to read and manipulate data.

Use-after-free vulnerability in core/dom/ContainerNode.cpp in the DOM implementation in Blink, as used in Google Chrome before 37.0.2062.94, allows remote attackers to cause a denial of service or possibly have unspecified other impact by leveraging script execution that occurs before notification of node removal. <a href="http://cwe.mitre.org/data/definitions/416.html" target="_blank">CWE-416: Use After Free</a>


Affected software

Opensuse
Debian Linux
Ubuntu
Google Chrome
liboxideqtcore0 (Ubuntu package)
oxideqt-codecs-extra (Ubuntu package)
oxideqt-codecs (Ubuntu package)

How to mitigate CVE-2014-3169

Install update from vendor's website.

liboxideqtcore0 (Ubuntu package) - update to 1.1.2-0ubuntu0.14.04.1
oxideqt-codecs-extra (Ubuntu package) - update to 1.1.2-0ubuntu0.14.04.1
oxideqt-codecs (Ubuntu package) - update to 1.1.2-0ubuntu0.14.04.1

External References

Related Security Bulletins