Improper Authentication in Django and Opensuse - CVE-2014-0482
Published: August 26, 2014 / Updated: August 10, 2020
Vulnerability details
The vulnerability allows a remote #AU# to read and manipulate data.
The contrib.auth.middleware.RemoteUserMiddleware middleware in Django before 1.4.14, 1.5.x before 1.5.9, 1.6.x before 1.6.6, and 1.7 before release candidate 3, when using the contrib.auth.backends.RemoteUserBackend backend, allows remote authenticated users to hijack web sessions via vectors related to the REMOTE_USER header.
Affected software
Opensuse
Gentoo Linux
Fedora
Ubuntu
python-django (Ubuntu package)
Django14
How to mitigate CVE-2014-0482
Django14 - update to 1.4.14-1.el6