Input validation error in Linux kernel - CVE-2014-4656

 

Input validation error in Linux kernel - CVE-2014-4656

Published: July 3, 2014 / Updated: August 10, 2020


Vulnerability identifier: #VU41505
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-4656
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

Multiple integer overflows in sound/core/control.c in the ALSA control implementation in the Linux kernel before 3.15.2 allow local users to cause a denial of service by leveraging /dev/snd/controlCX access, related to (1) index values in the snd_ctl_add function and (2) numid values in the snd_ctl_remove_numid_conflict function.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-trusty (Ubuntu package)

How to mitigate CVE-2014-4656

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-65.131, 3.2.0-68.102, 3.13.0-35.62
linux-lts-trusty (Ubuntu package) - update to 3.13.0-35.62~precise1

External References

Related Security Bulletins