Permissions, Privileges, and Access Controls in mod_wsgi - CVE-2014-0240
Published: May 27, 2014 / Updated: August 9, 2022
Vulnerability details
The vulnerability allows a local user to escalate privileges on the system.
The mod_wsgi module before 3.5 for Apache, when daemon mode is enabled, does not properly handle error codes returned by setuid when run on certain Linux kernels, which allows local users to gain privileges via vectors related to the number of running processes.
Affected software
libapache2-mod-wsgi (Ubuntu package)
libapache2-mod-wsgi-py3 (Ubuntu package)
python26-mod_wsgi
Amazon Linux AMI
Gentoo Linux
Fedora
Ubuntu
How to mitigate CVE-2014-0240
libapache2-mod-wsgi (Ubuntu package) - addressed in versions 3.3-4ubuntu0.1, 3.4-4ubuntu2.1.13.10.1, 3.4-4ubuntu2.1.14.04.1
libapache2-mod-wsgi-py3 (Ubuntu package) - addressed in versions 3.3-4ubuntu0.1, 3.4-4ubuntu2.1.13.10.1, 3.4-4ubuntu2.1.14.04.1
mod_wsgi - update to 3.5-1.el5
python26-mod_wsgi - update to 3.5-1.el5