Permissions, Privileges, and Access Controls in Linux kernel - CVE-2014-3122

 

Permissions, Privileges, and Access Controls in Linux kernel - CVE-2014-3122

Published: May 12, 2014 / Updated: August 10, 2020


Vulnerability identifier: #VU41698
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-3122
CWE-ID: CWE-264
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

The try_to_unmap_cluster function in mm/rmap.c in the Linux kernel before 3.14.3 does not properly consider which pages must be locked, which allows local users to cause a denial of service (system crash) by triggering a memory-usage pattern that requires removal of page-table mappings.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-image-2.6.32-365-ec2 (Ubuntu package)
linux-lts-quantal (Ubuntu package)
linux-lts-raring (Ubuntu package)
linux-lts-saucy (Ubuntu package)
linux-lts-trusty (Ubuntu package)

How to mitigate CVE-2014-3122

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-61.124, 3.2.0-64.97, 3.11.0-23.40, 3.13.0-29.53
linux-image-2.6.32-365-ec2 (Ubuntu package) - update to 2.6.32-365.79
linux-lts-quantal (Ubuntu package) - update to 3.5.0-51.76~precise1
linux-lts-raring (Ubuntu package) - update to 3.8.0-41.60~precise1
linux-lts-saucy (Ubuntu package) - update to 3.11.0-23.40~precise1
linux-lts-trusty (Ubuntu package) - update to 3.13.0-30.54~precise2

External References

Related Security Bulletins