Input validation error in Linux kernel - CVE-2014-0077

 

Input validation error in Linux kernel - CVE-2014-0077

Published: April 15, 2014 / Updated: August 10, 2020


Vulnerability identifier: #VU41816
CSH Severity: Medium
CVSS v4: 5.8 [CVSS:4.0/AV:A/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-0077
CWE-ID: CWE-20
Exploitation vector: Adjecent network
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote #AU# to #BASIC_IMPACT#.

drivers/vhost/net.c in the Linux kernel before 3.13.10, when mergeable buffers are disabled, does not properly validate packet lengths, which allows guest OS users to cause a denial of service (memory corruption and host OS crash) or possibly gain privileges on the host OS via crafted packets, related to the handle_rx and get_rx_bufs functions.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)
linux-lts-raring (Ubuntu package)
linux-lts-trusty (Ubuntu package)

How to mitigate CVE-2014-0077

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 3.2.0-63.95, 3.11.0-22.38, 3.13.0-27.50
linux-lts-quantal (Ubuntu package) - update to 3.5.0-51.76~precise1
linux-lts-raring (Ubuntu package) - update to 3.8.0-41.60~precise1
linux-lts-trusty (Ubuntu package) - update to 3.13.0-30.54~precise2

External References

Related Security Bulletins