Permissions, Privileges, and Access Controls in PostgreSQL - CVE-2014-0060

 

Permissions, Privileges, and Access Controls in PostgreSQL - CVE-2014-0060

Published: March 31, 2014 / Updated: August 10, 2020


Vulnerability identifier: #VU41880
CSH Severity: Low
CVSS v4: 5.1 [CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-0060
CWE-ID: CWE-264
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote #AU# to manipulate data.

PostgreSQL before 8.4.20, 9.0.x before 9.0.16, 9.1.x before 9.1.12, 9.2.x before 9.2.7, and 9.3.x before 9.3.3 does not properly enforce the ADMIN OPTION restriction, which allows remote authenticated members of a role to add or remove arbitrary users to that role by calling the SET ROLE command before the associated GRANT command.


Affected software

PostgreSQL
Amazon Linux AMI
Gentoo Linux
Ubuntu
postgresql-8.4 (Ubuntu package)
postgresql-9.1 (Ubuntu package)

How to mitigate CVE-2014-0060

Install update from vendor's website.

postgresql-8.4 (Ubuntu package) - update to 8.4.20-0ubuntu010.04
postgresql-9.1 (Ubuntu package) - addressed in versions 9.1.12-0ubuntu0.12.04, 9.1.12-0ubuntu0.12.10, 9.1.12-0ubuntu0.13.10

External References

Related Security Bulletins