Input validation error in Linux kernel - CVE-2014-2309

 

Input validation error in Linux kernel - CVE-2014-2309

Published: March 11, 2014 / Updated: August 10, 2020


Vulnerability identifier: #VU41948
CSH Severity: Medium
CVSS v4: 7.1 [CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-2309
CWE-ID: CWE-20
Exploitation vector: Adjecent network
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

The ip6_route_add function in net/ipv6/route.c in the Linux kernel through 3.13.6 does not properly count the addition of routes, which allows remote attackers to cause a denial of service (memory consumption) via a flood of ICMPv6 Router Advertisement packets.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)
linux-lts-raring (Ubuntu package)

How to mitigate CVE-2014-2309

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 3.2.0-63.95, 3.11.0-22.38
linux-lts-quantal (Ubuntu package) - update to 3.5.0-51.76~precise1
linux-lts-raring (Ubuntu package) - update to 3.8.0-41.60~precise1

External References

Related Security Bulletins