Input validation error in Linux kernel - CVE-2014-2038

 

Input validation error in Linux kernel - CVE-2014-2038

Published: February 28, 2014 / Updated: August 10, 2020


Vulnerability identifier: #VU41990
CSH Severity: Medium
CVSS v4: 2.1 [CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-2038
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to read and manipulate data.

The nfs_can_extend_write function in fs/nfs/write.c in the Linux kernel before 3.13.3 relies on a write delegation to extend a write operation without a certain up-to-date verification, which allows local users to obtain sensitive information from kernel memory in opportunistic circumstances by writing to a file in an NFS filesystem and then reading the same file.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-saucy (Ubuntu package)

How to mitigate CVE-2014-2038

Install update from vendor's website.

linux (Ubuntu package) - update to 3.11.0-18.32
linux-lts-saucy (Ubuntu package) - update to 3.11.0-18.32~precise1

External References

Related Security Bulletins