Input validation error in Linux kernel - CVE-2013-7263

 

Input validation error in Linux kernel - CVE-2013-7263

Published: January 6, 2014 / Updated: August 10, 2020


Vulnerability identifier: #VU42180
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-7263
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to gain access to sensitive information.

The Linux kernel before 3.12.4 updates certain length values before ensuring that associated data structures have been initialized, which allows local users to obtain sensitive information from kernel stack memory via a (1) recvfrom, (2) recvmmsg, or (3) recvmsg system call, related to net/ipv4/ping.c, net/ipv4/raw.c, net/ipv4/udp.c, net/ipv6/raw.c, and net/ipv6/udp.c.


Affected software

Linux kernel
Amazon Linux AMI
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)
linux-lts-raring (Ubuntu package)
linux-lts-saucy (Ubuntu package)

How to mitigate CVE-2013-7263

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-56.118, 3.2.0-59.90, 3.5.0-47.71, 3.11.0-17.31
linux-lts-quantal (Ubuntu package) - update to 3.5.0-47.71~precise1
linux-lts-raring (Ubuntu package) - update to 3.8.0-37.53~precise1
linux-lts-saucy (Ubuntu package) - update to 3.11.0-17.31~precise1

External References

Related Security Bulletins