Input validation error in FreeRDP - CVE-2014-0791

 

Input validation error in FreeRDP - CVE-2014-0791

Published: January 3, 2014 / Updated: August 10, 2020


Vulnerability identifier: #VU42191
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-0791
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to read and manipulate data.

Integer overflow in the license_read_scope_list function in libfreerdp/core/license.c in FreeRDP through 1.0.2 allows remote RDP servers to cause a denial of service (application crash) or possibly have unspecified other impact via a large ScopeCount value in a Scope List in a Server License Request packet.


Affected software

FreeRDP
Ubuntu
libfreerdp1 (Ubuntu package)
libfreerdp-client1.1 (Ubuntu package)

How to mitigate CVE-2014-0791

Install update from vendor's website.

libfreerdp1 (Ubuntu package) - update to 1.0.2-2ubuntu1.1
libfreerdp-client1.1 (Ubuntu package) - addressed in versions 1.1.0~git20140921.1.440916e+dfsg1-5ubuntu1.2, 1.1.0~git20140921.1.440916e+dfsg1-10ubuntu1.1

External References

Related Security Bulletins