Input validation error in Linux kernel - CVE-2013-4587

 

Input validation error in Linux kernel - CVE-2013-4587

Published: December 14, 2013 / Updated: August 10, 2020


Vulnerability identifier: #VU42229
CSH Severity: High
CVSS v4: 8.6 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-4587
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

Array index error in the kvm_vm_ioctl_create_vcpu function in virt/kvm/kvm_main.c in the KVM subsystem in the Linux kernel through 3.12.5 allows local users to gain privileges via a large id value.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)
linux-lts-raring (Ubuntu package)
linux-lts-saucy (Ubuntu package)

How to mitigate CVE-2013-4587

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-57.119, 3.2.0-59.90, 3.5.0-47.71, 3.11.0-17.31
linux-lts-quantal (Ubuntu package) - update to 3.5.0-47.71~precise1
linux-lts-raring (Ubuntu package) - update to 3.8.0-37.53~precise1
linux-lts-saucy (Ubuntu package) - update to 3.11.0-17.31~precise1

External References

Related Security Bulletins