Buffer overflow in Linux kernel - CVE-2013-6382

 

Buffer overflow in Linux kernel - CVE-2013-6382

Published: November 27, 2013 / Updated: August 10, 2020


Vulnerability identifier: #VU42307
CSH Severity: Medium
CVSS v4: 5.9 [CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-6382
CWE-ID: CWE-119
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

Multiple buffer underflows in the XFS implementation in the Linux kernel through 3.12.1 allow local users to cause a denial of service (memory corruption) or possibly have unspecified other impact by leveraging the CAP_SYS_ADMIN capability for a (1) XFS_IOC_ATTRLIST_BY_HANDLE or (2) XFS_IOC_ATTRLIST_BY_HANDLE_32 ioctl call with a crafted length value, related to the xfs_attrlist_by_handle function in fs/xfs/xfs_ioctl.c and the xfs_compat_attrlist_by_handle function in fs/xfs/xfs_ioctl32.c.


Affected software

Linux kernel
Amazon Linux AMI
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)
linux-lts-raring (Ubuntu package)
linux-lts-saucy (Ubuntu package)

How to mitigate CVE-2013-6382

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-57.119, 3.2.0-59.90, 3.5.0-47.71, 3.11.0-17.31
linux-lts-quantal (Ubuntu package) - update to 3.5.0-47.71~precise1
linux-lts-raring (Ubuntu package) - update to 3.8.0-38.56~precise1
linux-lts-saucy (Ubuntu package) - update to 3.11.0-17.31~precise1

External References

Related Security Bulletins