Input validation error in Linux kernel - CVE-2013-4511

 

Input validation error in Linux kernel - CVE-2013-4511

Published: November 12, 2013 / Updated: August 10, 2020


Vulnerability identifier: #VU42380
CSH Severity: High
CVSS v4: 8.6 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-4511
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

Multiple integer overflows in Alchemy LCD frame-buffer drivers in the Linux kernel before 3.12 allow local users to create a read-write memory mapping for the entirety of kernel memory, and consequently gain privileges, via crafted mmap operations, related to the (1) au1100fb_fb_mmap function in drivers/video/au1100fb.c and the (2) au1200fb_fb_mmap function in drivers/video/au1200fb.c.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)
linux-lts-raring (Ubuntu package)
linux-lts-saucy (Ubuntu package)

How to mitigate CVE-2013-4511

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-54.116, 3.2.0-58.88, 3.5.0-45.68, 3.8.0-35.50, 3.11.0-15.23
linux-lts-quantal (Ubuntu package) - update to 3.5.0-45.68~precise1
linux-lts-raring (Ubuntu package) - update to 3.8.0-35.50~precise1
linux-lts-saucy (Ubuntu package) - update to 3.11.0-15.23~precise1

External References

Related Security Bulletins