Buffer overflow in Linux kernel - CVE-2013-2892

 

Buffer overflow in Linux kernel - CVE-2013-2892

Published: September 16, 2013 / Updated: August 10, 2020


Vulnerability identifier: #VU42580
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-2892
CWE-ID: CWE-119
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

drivers/hid/hid-pl.c in the Human Interface Device (HID) subsystem in the Linux kernel through 3.11, when CONFIG_HID_PANTHERLORD is enabled, allows physically proximate attackers to cause a denial of service (heap-based out-of-bounds write) via a crafted device.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)
linux-lts-raring (Ubuntu package)

How to mitigate CVE-2013-2892

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-52.114, 3.2.0-57.87, 3.5.0-43.66, 3.8.0-32.47
linux-lts-quantal (Ubuntu package) - update to 3.5.0-43.66~precise1
linux-lts-raring (Ubuntu package) - update to 3.8.0-32.47~precise1

External References

Related Security Bulletins