Input validation error in Linux kernel - CVE-2013-2888

 

Input validation error in Linux kernel - CVE-2013-2888

Published: September 16, 2013 / Updated: August 10, 2020


Vulnerability identifier: #VU42587
CSH Severity: Medium
CVSS v4: 7.5 [CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-2888
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

Multiple array index errors in drivers/hid/hid-core.c in the Human Interface Device (HID) subsystem in the Linux kernel through 3.11 allow physically proximate attackers to execute arbitrary code or cause a denial of service (heap memory corruption) via a crafted device that provides an invalid Report ID.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)
linux-lts-raring (Ubuntu package)

How to mitigate CVE-2013-2888

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-52.114, 3.2.0-57.87, 3.5.0-43.66, 3.8.0-32.47
linux-lts-quantal (Ubuntu package) - update to 3.5.0-43.66~precise1
linux-lts-raring (Ubuntu package) - update to 3.8.0-32.47~precise1

External References

Related Security Bulletins