Buffer overflow in Linux kernel - CVE-2013-2237

 

Buffer overflow in Linux kernel - CVE-2013-2237

Published: July 5, 2013 / Updated: August 11, 2020


Vulnerability identifier: #VU42753
CSH Severity: Low
CVSS v4: 5.1 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-2237
CWE-ID: CWE-119
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to gain access to sensitive information.

The key_notify_policy_flush function in net/key/af_key.c in the Linux kernel before 3.9 does not initialize a certain structure member, which allows local users to obtain sensitive information from kernel heap memory by reading a broadcast message from the notify_policy interface of an IPSec key_socket.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)
linux-lts-raring (Ubuntu package)

How to mitigate CVE-2013-2237

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-50.112, 3.2.0-55.85, 3.5.0-41.64, 3.8.0-32.47
linux-lts-quantal (Ubuntu package) - update to 3.5.0-41.64~precise1
linux-lts-raring (Ubuntu package) - update to 3.8.0-32.47~precise1

External References

Related Security Bulletins