Heap-based buffer overflow in Linux kernel - CVE-2013-1929

 

Heap-based buffer overflow in Linux kernel - CVE-2013-1929

Published: June 7, 2013 / Updated: August 11, 2020


Vulnerability identifier: #VU42796
CSH Severity: Medium
CVSS v4: 5.1 [CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-1929
CWE-ID: CWE-122
Exploitation vector: Local access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error in Heap-based buffer overflow in the tg3_read_vpd function in drivers/net/ethernet/broadcom/tg3.c in the Linux kernel before 3.8.6. A remote attacker can use crafted firmware that specifies a long string in the Vital Product Data to trigger heap-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)

How to mitigate CVE-2013-1929

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

linux (Ubuntu package) - addressed in versions 3.2.0-44.69, 3.5.0-31.52
linux-lts-quantal (Ubuntu package) - update to 3.5.0-31.52~precise1

External References

Related Security Bulletins