Input validation error in Linux kernel - CVE-2013-1848

 

Input validation error in Linux kernel - CVE-2013-1848

Published: March 22, 2013 / Updated: August 11, 2020


Vulnerability identifier: #VU42969
CSH Severity: Medium
CVSS v4: 7.5 [CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-1848
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

fs/ext3/super.c in the Linux kernel before 3.8.4 uses incorrect arguments to functions in certain circumstances related to printk input, which allows local users to conduct format-string attacks and possibly gain privileges via a crafted application.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)

How to mitigate CVE-2013-1848

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 3.2.0-41.66, 3.5.0-28.48
linux-lts-quantal (Ubuntu package) - update to 3.5.0-28.48~precise1

External References

Related Security Bulletins