Heap-based buffer overflow in Linux kernel - CVE-2013-1860

 

Heap-based buffer overflow in Linux kernel - CVE-2013-1860

Published: March 22, 2013 / Updated: August 11, 2020


Vulnerability identifier: #VU42970
CSH Severity: High
CVSS v4: 8.6 [CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-1860
CWE-ID: CWE-122
Exploitation vector: Local access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote attacker to execute arbitrary code on the target system.

The vulnerability exists due to a boundary error in Heap-based buffer overflow in the wdm_in_callback function in drivers/usb/class/cdc-wdm.c in the Linux kernel before 3.8.4. A remote attacker can use a crafted cdc-wdm USB device. to trigger heap-based buffer overflow and execute arbitrary code on the target system.

Successful exploitation of this vulnerability may result in complete compromise of vulnerable system.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)

How to mitigate CVE-2013-1860

Cybersecurity Help is currently unaware of any official solution to address this vulnerability.

linux (Ubuntu package) - addressed in versions 2.6.32-47.109, 3.2.0-41.66, 3.5.0-28.48
linux-lts-quantal (Ubuntu package) - update to 3.5.0-28.48~precise1

External References

Related Security Bulletins