Input validation error in Linux kernel - CVE-2013-0228

 

Input validation error in Linux kernel - CVE-2013-0228

Published: March 1, 2013 / Updated: August 11, 2020


Vulnerability identifier: #VU43040
CSH Severity: Medium
CVSS v4: 7.5 [CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-0228
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

The xen_iret function in arch/x86/xen/xen-asm_32.S in the Linux kernel before 3.7.9 on 32-bit Xen paravirt_ops platforms does not properly handle an invalid value in the DS segment register, which allows guest OS users to gain guest OS privileges via a crafted application.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-image-2.6.32-351-ec2 (Ubuntu package)
linux-lts-backport-oneiric (Ubuntu package)
linux-lts-quantal (Ubuntu package)

How to mitigate CVE-2013-0228

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-46.108, 3.0.0-32.50, 3.2.0-39.62, 3.5.0-27.46
linux-image-2.6.32-351-ec2 (Ubuntu package) - update to 2.6.32-351.64
linux-lts-backport-oneiric (Ubuntu package) - update to 3.0.0-32.50~lucid1
linux-lts-quantal (Ubuntu package) - update to 3.5.0-27.46~precise1

External References

Related Security Bulletins