Input validation error in Linux kernel - CVE-2011-2905

 

Input validation error in Linux kernel - CVE-2011-2905

Published: March 1, 2013 / Updated: August 11, 2020


Vulnerability identifier: #VU43043
CSH Severity: Medium
CVSS v4: 7.5 [CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-2905
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

Untrusted search path vulnerability in the perf_config function in tools/perf/util/config.c in perf, as distributed in the Linux kernel before 3.1, allows local users to overwrite arbitrary files via a crafted config file in the current working directory. Per: http://cwe.mitre.org/data/definitions/426.html 'CWE-426 Untrusted Search Path'


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-backport-maverick (Ubuntu package)
linux-lts-backport-natty (Ubuntu package)

How to mitigate CVE-2011-2905

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-35.78, 2.6.35-30.61, 2.6.38-13.52
linux-lts-backport-maverick (Ubuntu package) - update to 2.6.35-30.61~lucid1
linux-lts-backport-natty (Ubuntu package) - update to 2.6.38-13.52~lucid1

External References

Related Security Bulletins