Input validation error in Linux kernel - CVE-2012-2669

 

Input validation error in Linux kernel - CVE-2012-2669

Published: December 27, 2012 / Updated: August 11, 2020


Vulnerability identifier: #VU43228
CSH Severity: Low
CVSS v4: 5.1 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N]
CVE-ID: CVE-2012-2669
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to manipulate data.

The main function in tools/hv/hv_kvp_daemon.c in hypervkvpd, as distributed in the Linux kernel before 3.4.5, does not validate the origin of Netlink messages, which allows local users to spoof Netlink communication via a crafted connector message.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-backport-oneiric (Ubuntu package)

How to mitigate CVE-2012-2669

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 3.0.0-31.48, 3.2.0-29.46
linux-lts-backport-oneiric (Ubuntu package) - update to 3.0.0-31.48~lucid1

External References

Related Security Bulletins