Input validation error in FFmpeg - CVE-2012-2776

 

Input validation error in FFmpeg - CVE-2012-2776

Published: September 11, 2012 / Updated: June 8, 2025


Vulnerability identifier: #VU43580
CSH Severity: High
CVSS v4: 8.6 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2012-2776
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

Unspecified vulnerability in the decode_cell_data function in libavcodec/indeo3.c in FFmpeg before 0.11 and Libav 0.8.x before 0.8.4 has unknown impact and attack vectors, related to an "out of picture write."


Affected software

FFmpeg
Ubuntu
libavformat53 (Ubuntu package)
libavcodec53 (Ubuntu package)

How to mitigate CVE-2012-2776

Install update from vendor's website.

FFmpeg - update to 0.11
libavformat53 (Ubuntu package) - addressed in versions 4:0.8.4-0ubuntu0.12.04.1, 6:0.8.4-0ubuntu0.12.10.1
libavcodec53 (Ubuntu package) - addressed in versions 4:0.8.4-0ubuntu0.12.04.1, 6:0.8.4-0ubuntu0.12.10.1

External References

Related Security Bulletins