Input validation error in FFmpeg - CVE-2012-2784
Published: September 11, 2012 / Updated: June 8, 2025
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.
Unspecified vulnerability in the decode_pic function in libavcodec/cavsdec.c in FFmpeg before 0.11, and Libav 0.7.x before 0.7.7 and 0.8.x before 0.8.4, has unknown impact and attack vectors, related to "width/height changing in CAVS," a different vulnerability than CVE-2012-2777.
Affected software
Ubuntu
libavformat52 (Ubuntu package)
libavcodec52 (Ubuntu package)
libavformat53 (Ubuntu package)
libavcodec53 (Ubuntu package)
How to mitigate CVE-2012-2784
libavformat52 (Ubuntu package) - update to 4:0.5.9-0ubuntu0.10.04.2
libavcodec52 (Ubuntu package) - update to 4:0.5.9-0ubuntu0.10.04.2
libavformat53 (Ubuntu package) - addressed in versions 4:0.7.6-0ubuntu0.11.10.2, 4:0.8.4-0ubuntu0.12.04.1, 6:0.8.4-0ubuntu0.12.10.1
libavcodec53 (Ubuntu package) - addressed in versions 4:0.7.6-0ubuntu0.11.10.2, 4:0.8.4-0ubuntu0.12.04.1, 6:0.8.4-0ubuntu0.12.10.1
External References
- http://ffmpeg.org/security.html
- http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=25715064c2ef4978672a91f8c856f3e8809a7c45
- http://libav.org/releases/libav-0.7.7.changelog
- http://libav.org/releases/libav-0.8.4.changelog
- http://secunia.com/advisories/50468
- http://secunia.com/advisories/51257
- http://www.mandriva.com/security/advisories?name=MDVSA-2013:079
- http://www.openwall.com/lists/oss-security/2012/08/31/3
- http://www.openwall.com/lists/oss-security/2012/09/02/4
- http://www.securityfocus.com/bid/55355