Buffer overflow in FFmpeg - CVE-2011-4579

 

Buffer overflow in FFmpeg - CVE-2011-4579

Published: August 20, 2012 / Updated: June 8, 2025


Vulnerability identifier: #VU43683
CSH Severity: Low
CVSS v4: 4.6 [CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-4579
CWE-ID: CWE-119
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

The svq1_decode_frame function in the SVQ1 decoder (svq1dec.c) in libavcodec in FFmpeg 0.5.x before 0.5.7, 0.6.x before 0.6.4, 0.7.x before 0.7.9, and 0.8.x before 0.8.8; and in Libav 0.5.x before 0.5.6, 0.6.x before 0.6.4, and 0.7.x before 0.7.3 allows remote attackers to cause a denial of service (memory corruption) via a crafted SVQ1 stream, related to "dimensions changed."


Affected software

FFmpeg
Ubuntu
libavformat52 (Ubuntu package)
libavcodec52 (Ubuntu package)
libavcodec53 (Ubuntu package)
libavformat53 (Ubuntu package)

How to mitigate CVE-2011-4579

Install update from vendor's website.

FFmpeg - update to 0.11
libavformat52 (Ubuntu package) - addressed in versions 4:0.5.1-1ubuntu1.3, 4:0.6-2ubuntu6.3, 4:0.6.4-0ubuntu0.11.04.1
libavcodec52 (Ubuntu package) - addressed in versions 4:0.5.1-1ubuntu1.3, 4:0.6-2ubuntu6.3, 4:0.6.4-0ubuntu0.11.04.1
libavcodec53 (Ubuntu package) - update to 4:0.7.3-0ubuntu0.11.10.1
libavformat53 (Ubuntu package) - update to 4:0.7.3-0ubuntu0.11.10.1

External References

Related Security Bulletins