Buffer overflow in FFmpeg - CVE-2011-4353
Published: August 20, 2012 / Updated: June 8, 2025
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to perform service disruption.
The (1) av_image_fill_pointers, (2) vp5_parse_coeff, and (3) vp6_parse_coeff functions in FFmpeg 0.5.x before 0.5.7, 0.6.x before 0.6.4, 0.7.x before 0.7.9, and 0.8.x before 0.8.8; and in Libav 0.5.x before 0.5.6, 0.6.x before 0.6.4, and 0.7.x before 0.7.3 allow remote attackers to cause a denial of service (out-of-bounds read) via a crafted VP5 or VP6 stream.
Affected software
Ubuntu
libavformat52 (Ubuntu package)
libavcodec52 (Ubuntu package)
libavcodec53 (Ubuntu package)
libavformat53 (Ubuntu package)
How to mitigate CVE-2011-4353
libavformat52 (Ubuntu package) - addressed in versions 4:0.5.1-1ubuntu1.3, 4:0.6-2ubuntu6.3, 4:0.6.4-0ubuntu0.11.04.1
libavcodec52 (Ubuntu package) - addressed in versions 4:0.5.1-1ubuntu1.3, 4:0.6-2ubuntu6.3, 4:0.6.4-0ubuntu0.11.04.1
libavcodec53 (Ubuntu package) - update to 4:0.7.3-0ubuntu0.11.10.1
libavformat53 (Ubuntu package) - update to 4:0.7.3-0ubuntu0.11.10.1
External References
- http://ffmpeg.org/
- http://libav.org/
- http://libav.org/releases/libav-0.5.6.changelog
- http://libav.org/releases/libav-0.6.4.changelog
- http://libav.org/releases/libav-0.7.3.changelog
- http://ubuntu.com/usn/usn-1320-1
- http://ubuntu.com/usn/usn-1333-1
- http://www.mandriva.com/security/advisories?name=MDVSA-2012:074
- http://www.mandriva.com/security/advisories?name=MDVSA-2012:075
- http://www.mandriva.com/security/advisories?name=MDVSA-2012:076