Input validation error in Linux kernel - CVE-2011-1476

 

Input validation error in Linux kernel - CVE-2011-1476

Published: June 22, 2012 / Updated: August 11, 2020


Vulnerability identifier: #VU43953
CSH Severity: Medium
CVSS v4: 5.9 [CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-1476
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

Integer underflow in the Open Sound System (OSS) subsystem in the Linux kernel before 2.6.39 on unspecified non-x86 platforms allows local users to cause a denial of service (memory corruption) by leveraging write access to /dev/sequencer.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-backport-maverick (Ubuntu package)

How to mitigate CVE-2011-1476

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.24-31.99, 2.6.32-32.62, 2.6.35-30.54, 2.6.38-10.46
linux-lts-backport-maverick (Ubuntu package) - update to 2.6.35-30.56~lucid1

External References

Related Security Bulletins