Input validation error in Linux kernel - CVE-2011-1493

 

Input validation error in Linux kernel - CVE-2011-1493

Published: June 22, 2012 / Updated: August 11, 2020


Vulnerability identifier: #VU43955
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-1493
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to read and manipulate data.

Array index error in the rose_parse_national function in net/rose/rose_subr.c in the Linux kernel before 2.6.39 allows remote attackers to cause a denial of service (heap memory corruption) or possibly have unspecified other impact by composing FAC_NATIONAL_DIGIS data that specifies a large number of digipeaters, and then sending this data to a ROSE socket.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-image-2.6.32-318-ec2 (Ubuntu package)
linux-lts-backport-maverick (Ubuntu package)
linux-lts-backport-natty (Ubuntu package)

How to mitigate CVE-2011-1493

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.24-29.93, 2.6.32-34.77, 2.6.35-30.59, 2.6.38-11.50
linux-image-2.6.32-318-ec2 (Ubuntu package) - update to 2.6.32-318.38
linux-lts-backport-maverick (Ubuntu package) - update to 2.6.35-30.59~lucid1
linux-lts-backport-natty (Ubuntu package) - update to 2.6.38-12.51~lucid1

External References

Related Security Bulletins