Input validation error in Linux kernel - CVE-2012-2383

 

Input validation error in Linux kernel - CVE-2012-2383

Published: June 13, 2012 / Updated: August 11, 2020


Vulnerability identifier: #VU43983
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2012-2383
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

Integer overflow in the i915_gem_execbuffer2 function in drivers/gpu/drm/i915/i915_gem_execbuffer.c in the Direct Rendering Manager (DRM) subsystem in the Linux kernel before 3.3.5 on 32-bit platforms allows local users to cause a denial of service (out-of-bounds write) or possibly have unspecified other impact via a crafted ioctl call.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-backport-oneiric (Ubuntu package)

How to mitigate CVE-2012-2383

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 3.0.0-21.35, 3.2.0-25.40
linux-lts-backport-oneiric (Ubuntu package) - update to 3.0.0-21.35~lucid1

External References

Related Security Bulletins