Input validation error in Linux kernel - CVE-2011-2496

 

Input validation error in Linux kernel - CVE-2011-2496

Published: June 13, 2012 / Updated: August 11, 2020


Vulnerability identifier: #VU43988
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-2496
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

Integer overflow in the vma_to_resize function in mm/mremap.c in the Linux kernel before 2.6.39 allows local users to cause a denial of service (BUG_ON and system crash) via a crafted mremap system call that expands a memory mapping.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-backport-maverick (Ubuntu package)
linux-lts-backport-natty (Ubuntu package)

How to mitigate CVE-2011-2496

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.24-30.96, 2.6.32-36.79, 2.6.35-31.62, 2.6.38-10.46
linux-lts-backport-maverick (Ubuntu package) - update to 2.6.35-31.62~lucid1
linux-lts-backport-natty (Ubuntu package) - update to 2.6.38-12.51~lucid1

External References

Related Security Bulletins