Input validation error in Linux kernel - CVE-2011-1767

 

Input validation error in Linux kernel - CVE-2011-1767

Published: June 13, 2012 / Updated: August 11, 2020


Vulnerability identifier: #VU43990
CSH Severity: Medium
CVSS v4: 8.2 [CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-1767
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

net/ipv4/ip_gre.c in the Linux kernel before 2.6.34, when ip_gre is configured as a module, allows remote attackers to cause a denial of service (OOPS) by sending a packet during module loading.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-image-2.6.32-318-ec2 (Ubuntu package)
linux-lts-backport-natty (Ubuntu package)

How to mitigate CVE-2011-1767

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.24-30.96, 2.6.32-34.77
linux-image-2.6.32-318-ec2 (Ubuntu package) - update to 2.6.32-318.38
linux-lts-backport-natty (Ubuntu package) - update to 2.6.38-12.51~lucid1

External References

Related Security Bulletins