Input validation error in Linux kernel - CVE-2011-2493

 

Input validation error in Linux kernel - CVE-2011-2493

Published: June 13, 2012 / Updated: August 11, 2020


Vulnerability identifier: #VU43999
CSH Severity: Low
CVSS v4: 5.1 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-2493
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

The ext4_fill_super function in fs/ext4/super.c in the Linux kernel before 2.6.39 does not properly initialize a certain error-report data structure, which allows local users to cause a denial of service (OOPS) by attempting to mount a crafted ext4 filesystem.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-backport-natty (Ubuntu package)

How to mitigate CVE-2011-2493

Install update from vendor's website.

linux (Ubuntu package) - update to 2.6.38-11.48
linux-lts-backport-natty (Ubuntu package) - update to 2.6.38-12.51~lucid1

External References

Related Security Bulletins