Input validation error in Linux kernel - CVE-2011-1759

 

Input validation error in Linux kernel - CVE-2011-1759

Published: June 13, 2012 / Updated: August 11, 2020


Vulnerability identifier: #VU44000
CSH Severity: Medium
CVSS v4: 7.5 [CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-1759
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

Integer overflow in the sys_oabi_semtimedop function in arch/arm/kernel/sys_oabi-compat.c in the Linux kernel before 2.6.39 on the ARM platform, when CONFIG_OABI_COMPAT is enabled, allows local users to gain privileges or cause a denial of service (heap memory corruption) by providing a crafted argument and leveraging a race condition.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-image-2.6.32-317-ec2 (Ubuntu package)
linux-lts-backport-maverick (Ubuntu package)

How to mitigate CVE-2011-1759

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-33.70, 2.6.35-32.64, 2.6.38-10.46
linux-image-2.6.32-317-ec2 (Ubuntu package) - update to 2.6.32-317.36
linux-lts-backport-maverick (Ubuntu package) - update to 2.6.35-32.64~lucid1

External References

Related Security Bulletins