Buffer overflow in Linux kernel - CVE-2011-2517

 

Buffer overflow in Linux kernel - CVE-2011-2517

Published: May 25, 2012 / Updated: August 11, 2020


Vulnerability identifier: #VU44037
CSH Severity: High
CVSS v4: 8.6 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-2517
CWE-ID: CWE-119
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

Multiple buffer overflows in net/wireless/nl80211.c in the Linux kernel before 2.6.39.2 allow local users to gain privileges by leveraging the CAP_NET_ADMIN capability during scan operations with a long SSID value.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-backport-maverick (Ubuntu package)
linux-lts-backport-natty (Ubuntu package)

How to mitigate CVE-2011-2517

Install update from vendor's website.

Linux kernel - update to 2.6.39.2
linux (Ubuntu package) - addressed in versions 2.6.32-36.79, 2.6.35-31.62, 2.6.38-13.52
linux-lts-backport-maverick (Ubuntu package) - update to 2.6.35-31.62~lucid1
linux-lts-backport-natty (Ubuntu package) - update to 2.6.38-13.52~lucid1

External References

Related Security Bulletins