Input validation error in Linux kernel - CVE-2011-1746

 

Input validation error in Linux kernel - CVE-2011-1746

Published: May 9, 2011 / Updated: August 11, 2020


Vulnerability identifier: #VU45057
CSH Severity: High
CVSS v4: 8.6 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-1746
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

Multiple integer overflows in the (1) agp_allocate_memory and (2) agp_create_user_memory functions in drivers/char/agp/generic.c in the Linux kernel before 2.6.38.5 allow local users to trigger buffer overflows, and consequently cause a denial of service (system crash) or possibly have unspecified other impact, via vectors related to calls that specify a large number of memory pages.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-image-2.6.32-317-ec2 (Ubuntu package)
linux-lts-backport-maverick (Ubuntu package)

How to mitigate CVE-2011-1746

Install update from vendor's website.

Linux kernel - update to 2.6.38.5
linux (Ubuntu package) - addressed in versions 2.6.32-33.70, 2.6.35-30.56, 2.6.38-10.46
linux-image-2.6.32-317-ec2 (Ubuntu package) - update to 2.6.32-317.36
linux-lts-backport-maverick (Ubuntu package) - update to 2.6.35-30.56~lucid1

External References

Related Security Bulletins