Input validation error in Linux kernel - CVE-2011-1495

 

Input validation error in Linux kernel - CVE-2011-1495

Published: May 3, 2011 / Updated: August 11, 2020


Vulnerability identifier: #VU45094
CSH Severity: High
CVSS v4: 8.6 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-1495
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

drivers/scsi/mpt2sas/mpt2sas_ctl.c in the Linux kernel 2.6.38 and earlier does not validate (1) length and (2) offset values before performing memory copy operations, which might allow local users to gain privileges, cause a denial of service (memory corruption), or obtain sensitive information from kernel memory via a crafted ioctl call, related to the _ctl_do_mpt_command and _ctl_diag_read_buffer functions.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-image-2.6.32-317-ec2 (Ubuntu package)
linux-lts-backport-maverick (Ubuntu package)

How to mitigate CVE-2011-1495

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-33.70, 2.6.35-30.54, 2.6.38-10.46
linux-image-2.6.32-317-ec2 (Ubuntu package) - update to 2.6.32-317.36
linux-lts-backport-maverick (Ubuntu package) - update to 2.6.35-30.56~lucid1

External References

Related Security Bulletins