Input validation error in PHP - CVE-2011-1466

 

Input validation error in PHP - CVE-2011-1466

Published: March 20, 2011 / Updated: August 11, 2020


Vulnerability identifier: #VU45185
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-1466
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform service disruption.

Integer overflow in the SdnToJulian function in the Calendar extension in PHP before 5.3.6 allows context-dependent attackers to cause a denial of service (application crash) via a large integer in the first argument to the cal_from_jd function.


Affected software

PHP
Gentoo Linux
Ubuntu
php5-common (Ubuntu package)
php5-cli (Ubuntu package)
php5 (Ubuntu package)
php-pear (Ubuntu package)
php5-gd (Ubuntu package)
libapache2-mod-php5 (Ubuntu package)
php5-curl (Ubuntu package)
php5-cgi (Ubuntu package)
php5-dev (Ubuntu package)
php5-intl (Ubuntu package)
dev-lang/php

How to mitigate CVE-2011-1466

Install update from vendor's website.

php5-common (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php5-cli (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php5 (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php-pear (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php5-gd (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
libapache2-mod-php5 (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php5-curl (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php5-cgi (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php5-dev (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php5-intl (Ubuntu package) - addressed in versions 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
dev-lang/php - update to 5.3.8

External References

Related Security Bulletins