Input validation error in Linux kernel - CVE-2011-1016

 

Input validation error in Linux kernel - CVE-2011-1016

Published: February 28, 2011 / Updated: August 11, 2020


Vulnerability identifier: #VU45289
CSH Severity: High
CVSS v4: 8.6 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2011-1016
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to execute arbitrary code.

The Radeon GPU drivers in the Linux kernel before 2.6.38-rc5 do not properly validate data related to the AA resolve registers, which allows local users to write to arbitrary memory locations associated with (1) Video RAM (aka VRAM) or (2) the Graphics Translation Table (GTT) via crafted values.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-backport-maverick (Ubuntu package)

How to mitigate CVE-2011-1016

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 2.6.32-32.62, 2.6.35-30.54
linux-lts-backport-maverick (Ubuntu package) - update to 2.6.35-30.56~lucid1

External References

Related Security Bulletins