Resource management error in PHP - CVE-2010-4697
Published: January 18, 2011 / Updated: August 11, 2020
Vulnerability details
The vulnerability allows a remote non-authenticated attacker to read and manipulate data.
Use-after-free vulnerability in the Zend engine in PHP before 5.2.15 and 5.3.x before 5.3.4 might allow context-dependent attackers to cause a denial of service (heap memory corruption) or have unspecified other impact via vectors related to use of __set, __get, __isset, and __unset methods on objects accessed by a reference.
Affected software
Gentoo Linux
Ubuntu
php5-common (Ubuntu package)
php5-cli (Ubuntu package)
php5 (Ubuntu package)
php-pear (Ubuntu package)
php5-gd (Ubuntu package)
libapache2-mod-php5 (Ubuntu package)
php5-curl (Ubuntu package)
php5-cgi (Ubuntu package)
php5-dev (Ubuntu package)
php5-intl (Ubuntu package)
dev-lang/php
How to mitigate CVE-2010-4697
php5-cli (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php5 (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php-pear (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php5-gd (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
libapache2-mod-php5 (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php5-curl (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php5-cgi (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php5-dev (Ubuntu package) - addressed in versions 5.1.2-1ubuntu3.22, 5.2.4-2ubuntu5.15, 5.2.10.dfsg.1-2ubuntu6.9, 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
php5-intl (Ubuntu package) - addressed in versions 5.3.2-1ubuntu4.8, 5.3.3-1ubuntu9.4, 5.3.5-1ubuntu7.1
dev-lang/php - update to 5.3.8
External References
- http://bugs.php.net/52879
- http://marc.info/?l=bugtraq&m=133469208622507&w=2
- http://www.php.net/ChangeLog-5.php
- http://www.securityfocus.com/bid/45952
- https://exchange.xforce.ibmcloud.com/vulnerabilities/65310
- https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A12528