Input validation error in Linux kernel - CVE-2010-3086

 

Input validation error in Linux kernel - CVE-2010-3086

Published: January 15, 2011 / Updated: August 11, 2020


Vulnerability identifier: #VU45444
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2010-3086
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

include/asm-x86/futex.h in the Linux kernel before 2.6.25 does not properly implement exception fixup, which allows local users to cause a denial of service (panic) via an invalid application that triggers a page fault.


Affected software

Linux kernel
Ubuntu
linux-source-2.6.15 (Ubuntu package)

How to mitigate CVE-2010-3086

Install update from vendor's website.

linux-source-2.6.15 (Ubuntu package) - update to 2.6.15-55.93

External References

Related Security Bulletins