Input validation error in Linux kernel - CVE-2014-1874

 

Input validation error in Linux kernel - CVE-2014-1874

Published: February 28, 2014 / Updated: September 8, 2020


Vulnerability identifier: #VU46362
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-1874
CWE-ID: CWE-20
Exploitation vector: Remote access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote non-authenticated attacker to perform a denial of service (DoS) attack.

The security_context_to_sid_core function in security/selinux/ss/services.c in the Linux kernel before 3.13.4 allows local users to cause a denial of service (system crash) by leveraging the CAP_MAC_ADMIN capability to set a zero-length security context.


Affected software

Linux kernel
Amazon Linux AMI
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)
linux-lts-raring (Ubuntu package)
linux-lts-saucy (Ubuntu package)

How to mitigate CVE-2014-1874

Install update from vendor's website.

Linux kernel - update to 3.13.4
linux (Ubuntu package) - addressed in versions 2.6.32-57.119, 3.2.0-60.91, 3.5.0-47.71, 3.11.0-18.32
linux-lts-quantal (Ubuntu package) - update to 3.5.0-47.71~precise1
linux-lts-raring (Ubuntu package) - update to 3.8.0-37.53~precise1
linux-lts-saucy (Ubuntu package) - update to 3.11.0-18.32~precise1

External References

Related Security Bulletins