Resource management errors in Linux kernel - CVE-2013-2147

 

Resource management errors in Linux kernel - CVE-2013-2147

Published: June 7, 2013 / Updated: January 9, 2018


Vulnerability identifier: #VU92811
CSH Severity: Low
CVSS v4: 4.8 [CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-2147
CWE-ID: CWE-399
Exploitation vector: Local access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a local user to gain access to sensitive information.

The HP Smart Array controller disk-array driver and Compaq SMART2 controller disk-array driver in the Linux kernel through 3.9.4 do not initialize certain data structures, which allows local users to obtain sensitive information from kernel memory via (1) a crafted IDAGETPCIINFO command for a /dev/ida device, related to the ida_locked_ioctl function in drivers/block/cpqarray.c or (2) a crafted CCISS_PASSTHRU32 command for a /dev/cciss device, related to the cciss_ioctl32_passthru function in drivers/block/cciss.c.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)
linux-lts-raring (Ubuntu package)

How to mitigate CVE-2013-2147

Install update from vendor's repository.

linux (Ubuntu package) - addressed in versions 2.6.32-53.115, 3.2.0-56.86, 3.5.0-42.65, 3.8.0-33.48
linux-lts-quantal (Ubuntu package) - update to 3.5.0-42.65~precise1
linux-lts-raring (Ubuntu package) - update to 3.8.0-33.48~precise1

External References

Related Security Bulletins