Security restrictions bypass in Linux kernel - CVE-2009-1630

 

Security restrictions bypass in Linux kernel - CVE-2009-1630

Published: May 14, 2009 / Updated: August 21, 2020


Vulnerability identifier: #VU92842
CSH Severity: Low
CVSS v4: 4.8 [CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N]
CVE-ID: CVE-2009-1630
CWE-ID: CWE-264
Exploitation vector: Local access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a local user to read and manipulate data.

The nfs_permission function in fs/nfs/dir.c in the NFS client implementation in the Linux kernel 2.6.29.3 and earlier, when atomic_open is available, does not check execute (aka EXEC or MAY_EXEC) permission bits, which allows local users to bypass permissions and execute files, as demonstrated by files on an NFSv4 fileserver.


Affected software

Linux kernel
Ubuntu
linux-source-2.6.15 (Ubuntu package)
linux (Ubuntu package)

How to mitigate CVE-2009-1630

Install update from vendor's repository.

linux-source-2.6.15 (Ubuntu package) - update to 2.6.15-54.77
linux (Ubuntu package) - addressed in versions 2.6.24-24.55, 2.6.27-14.35, 2.6.28-13.45

External References

Related Security Bulletins