Security restrictions bypass in Linux kernel - CVE-2009-0835

 

Security restrictions bypass in Linux kernel - CVE-2009-0835

Published: March 6, 2009 / Updated: June 20, 2024


Vulnerability identifier: #VU92845
CSH Severity: Low
CVSS v4: 4.8 [CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N]
CVE-ID: CVE-2009-0835
CWE-ID: CWE-264
Exploitation vector: Local access
Exploit availability: Public exploit is available

Vulnerability details

The vulnerability allows a local user to read and manipulate data.

The __secure_computing function in kernel/seccomp.c in the seccomp subsystem in the Linux kernel 2.6.28.7 and earlier on the x86_64 platform, when CONFIG_SECCOMP is enabled, does not properly handle (1) a 32-bit process making a 64-bit syscall or (2) a 64-bit process making a 32-bit syscall, which allows local users to bypass intended access restrictions via crafted syscalls that are misinterpreted as (a) stat or (b) chmod, a related issue to CVE-2009-0342 and CVE-2009-0343.


Affected software

Linux kernel
Ubuntu
linux-source-2.6.15 (Ubuntu package)
linux-source-2.6.22 (Ubuntu package)
linux (Ubuntu package)

How to mitigate CVE-2009-0835

Install update from vendor's repository.

linux-source-2.6.15 (Ubuntu package) - update to 2.6.15-54.76
linux-source-2.6.22 (Ubuntu package) - update to 2.6.22-16.62
linux (Ubuntu package) - addressed in versions 2.6.24-23.52, 2.6.27-11.31

Links to Public Exploits and PoC-codes

External References

Related Security Bulletins