Input validation error in Linux kernel - CVE-2009-2849

 

Input validation error in Linux kernel - CVE-2009-2849

Published: August 19, 2009 / Updated: September 19, 2017


Vulnerability identifier: #VU93725
CSH Severity: Low
CVSS v4: 6.8 [CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2009-2849
CWE-ID: CWE-20
Exploitation vector: Local access
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a local user to perform a denial of service (DoS) attack.

The md driver (drivers/md/md.c) in the Linux kernel before 2.6.30.2 might allow local users to cause a denial of service (NULL pointer dereference) via vectors related to 'suspend_* sysfs attributes' and the (1) suspend_lo_store or (2) suspend_hi_store functions. NOTE: this is only a vulnerability when sysfs is writable by an attacker.


Affected software

Linux kernel
Ubuntu
linux-source-2.6.15 (Ubuntu package)
linux (Ubuntu package)

How to mitigate CVE-2009-2849

Install update from vendor's website.

linux-source-2.6.15 (Ubuntu package) - update to 2.6.15-55.80
linux (Ubuntu package) - addressed in versions 2.6.24-25.63, 2.6.27-15.43, 2.6.28-16.55

External References

Related Security Bulletins