Input validation error in Linux kernel - CVE-2014-0055

 

Input validation error in Linux kernel - CVE-2014-0055

Published: March 26, 2014 / Updated: April 22, 2019


Vulnerability identifier: #VU94160
CSH Severity: Medium
CVSS v4: 6.9 [CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2014-0055
CWE-ID: CWE-20
Exploitation vector: Adjecent network
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote user to perform a denial of service (DoS) attack.

The get_rx_bufs function in drivers/vhost/net.c in the vhost-net subsystem in the Linux kernel package before 2.6.32-431.11.2 on Red Hat Enterprise Linux (RHEL) 6 does not properly handle vhost_get_vq_desc errors, which allows guest OS users to cause a denial of service (host OS crash) via unspecified vectors.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-quantal (Ubuntu package)
linux-lts-raring (Ubuntu package)

How to mitigate CVE-2014-0055

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 3.2.0-64.97, 3.11.0-22.38
linux-lts-quantal (Ubuntu package) - update to 3.5.0-51.76~precise1
linux-lts-raring (Ubuntu package) - update to 3.8.0-41.60~precise1

External References

Related Security Bulletins