Input validation error in Linux kernel - CVE-2013-0311

 

Input validation error in Linux kernel - CVE-2013-0311

Published: February 22, 2013 / Updated: February 13, 2023


Vulnerability identifier: #VU94162
CSH Severity: Medium
CVSS v4: 7.5 [CVSS:4.0/AV:A/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N]
CVE-ID: CVE-2013-0311
CWE-ID: CWE-20
Exploitation vector: Adjecent network
Exploit availability: No public exploit available

Vulnerability details

The vulnerability allows a remote user to execute arbitrary code.

The translate_desc function in drivers/vhost/vhost.c in the Linux kernel before 3.7 does not properly handle cross-region descriptors, which allows guest OS users to obtain host OS privileges by leveraging KVM guest OS privileges.


Affected software

Linux kernel
Ubuntu
linux (Ubuntu package)
linux-lts-backport-oneiric (Ubuntu package)
linux-lts-quantal (Ubuntu package)

How to mitigate CVE-2013-0311

Install update from vendor's website.

linux (Ubuntu package) - addressed in versions 3.0.0-32.50, 3.2.0-39.62, 3.5.0-26.42
linux-lts-backport-oneiric (Ubuntu package) - update to 3.0.0-32.50~lucid1
linux-lts-quantal (Ubuntu package) - update to 3.5.0-26.42~precise1

External References

Related Security Bulletins